Ocaml 在 WSL 上需要 bwrap 的解决方法

最新版的 ocaml 依赖 bwrap,而 wsl 不支持 bwrap,因此 opam 里很多工具用不了,基本上是废了。

找了一下网上的解决方案:

https://stackoverflow.com/questions/54987110/installing-ocaml-on-windows-10-using-wsl-ubuntu-problems-with-bwrap-bubblewr

首先 APT 安装

sudo apt install ocaml opam m4

接下来初始化 opam 需要启用 disable-sandboxing

cd ~
sudo rm -r .opam
opam init --disable-sandboxing

之后就可以安装 merlin 之类的插件啦

opam install merlin ocp-indent omake utop menhir

快速设置环境(全选 y)

opam user-setup install

0 Comments (604 Views)

Leave a Reply

Your email address will not be published. Required fields are marked *